
2020/2040 SERIES 

Squirrel Data Logger 

Getting Started 

 

ES 

 

IT 

 

DE 

 

FR 

 

EN 



 

Version 13 - Nov 2009   18108 
Page 1 

 www.grant.co.uk 

Contents 

1. Hardware Checklist............................................................................2 
 
2. General Information...........................................................................3 
 
3. Communicating with your Logger ...................................................4 
 
4. Quick Start Example..........................................................................8 
 
5. Download Process Explained.........................................................12 
 
6. Menu and Navigation.......................................................................13 
 
7. Connections.....................................................................................15 
 
8. Accessories......................................................................................17 
 
9. Specifications...................................................................................19 
 
10. Declaration of Conformity....................................inside rear cover 

After reading this document, 
please refer to the Help contents  
within SquirrelView (press F1) for  
further details on your logger and  
how to use it with the software. 
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A) SQ2020/2040 Logger   
B) CD containing software (SQA100) 
C) Getting Started manual (this booklet)   
D) USB Cable (LC77) 
E) Mounting bracket/stand for logger (WB6) 
F) Batteries, 6 x AA  
G) Current shunt resistors for 4 to 20mA inputs, 10R x 4 (CS202)  
H) Connectors: 6 way x 4 (18097), 4 way (13975), 3 way 

(14174), with cable ties 
 
Note: 2040 Logger is supplied with 4 extra 6 way connectors 

as above (18097). 
 Wi-fi version also contains an antenna. 

1. Hardware Checklist 

A 
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C 
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2. General Information 

The 2020/2040 uses six AA size alkaline batteries located under the removable cover 
shown below. To insert new or change the existing batteries: 
 1. Open the battery cover by pushing down and sliding as shown. 
 2. Insert six AA* batteries, ensuring the correct polarity. 
 3. Refit the battery cover 
 
* It is recommended that all replacement batteries are of the same manufacturer, type 
and condition. 

2.1 Installing the batteries 

2.2 Power indicator 

 Battery indicator 
 When logging please ensure that the batteries in the unit have sufficient capacity to 
 complete the logging task. This can be checked via the battery indicator located in the 
 top right of the display. 
    
   HIGH   LOW 
   CAPACITY  CAPACITY 
 
 External power indicator 
 The logger may be powered from an external source (10-18V DC) 

Important: To ensure data protection in the case of an unexpected  
power loss, please ensure that batteries are fitted whilst the unit is  
operational. 
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Important: Please ensure the software is installed before connecting the Squirrel data 
logger. 

3. Communicating with your Logger  

3.1 Installing the Software 

* If after a few minutes autorun has not occurred select the Run option from the Windows 
Start Menu. In the Command Line box, type d:\setup and press enter (where d:\ is your 
CD\DVD drive, modify if required) 

For detailed installation instructions please see the supplied óSoftware Installation Guideô 
supplement. For quick installation please see the steps below; 
 

1. Ensure you have administration rights on the PC you wish to install software on  
2. Ensure any current Grant applications are closed 
3. Insert the CD into the CD\DVD drive of your computer and wait for it to autorun* 
4. Follow the on screen installation wizard 

3.2 Connecting your Squirrel Data Logger 

You can connect to your logger by using one of the following methods;  
 
 1. Serial (RS232), including serial adaptors 
 2. USB 
 3. Ethernet (where fitted) 
 4. Wi-fi (where fitted) 
 
Please see below for more information. 
 
Serial (RS232) 
For information on using serial adaptors please see the SquirrelView help file. If using a 
straight serial (RS232) cable, connect one end to the serial port on the logger and the other 
end to the PCôs serial port. Once connected you are ready to begin communications. 
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Win 2000/XP - During the installation the USB drivers were pre-installed so the wizard will  
automatically locate the driver. On the óFound New Hardware Wizardô select óNo, not this 
timeô and for all the other screens select óNextô to complete the installation.  

On detection of the logger the PC will launch the driver installation wizard.  

USB 
Connect one end of the supplied USB lead to the logger and the other end to the PC. 
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Win 98SE  -  Select Search for the best driver for your device (Recommended), click 
Next.  Tick Specify a location, Browse to ó~\SquirrelView\Drivers\20xx USBô where 
ó~\SquirrelViewô is the installation directory of SquirrelView and then click Next. 

Select Continue Anyway on the Hardware Installation warning which refers to Windows 
Logo testing. Once the driver installation has completed you are ready to communicate to 
your logger. 
 
If you experience any problems refer to Troubleshooting->20xx USB Drivers in SquirrelView 
Help. 

 

Ethernet 
Before using the Ethernet connection please read the configuration manual which can be 
found under ó~\SquirrelView\Manuals\SQ20xx Inbuilt Ethernet Configuration.pdfô where 
ó~\SquirrelViewô is the installation directory of SquirrelView. Connect your Ethernet network 
to the Ethernet port on the logger. 

Ethernet is only available when the logger is connected to an external power supply.  
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Wi-fi 
Before using the Wi-fi connection it is necessary to assemble the antenna to the logger as 
shown below. 
 

1. Screw the antenna onto the threaded socket and orient it in the same direction as 
the antenna on the receiver connected to the PC (usually vertical). 

2. Attach an external power supply to the logger. 
3. Turning on the power will cause the yellow and green lights on the module to start 

flashing.  A connection has been established when the yellow light stays on 
permanently. 

Wi-fi is only available when the logger is connected to an external power supply.  

3 

2 

1 

To complete the installation please refer to the configuration manual which can be found 
under ó~\SquirrelView\Manuals\SQ20xx Inbuilt Ethernet Configuration.pdfô where 
ó~\SquirrelViewô is the installation directory of SquirrelView.  
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4. Quick Start Example 

    From  
SquirrelView Assistant 
click on Logger 
Setup.      

    From the Logger 
Setup screen select 
the Logger Control 
tab. 
Click on óSet Logger 
Time to PC Timeô, 
click OK on the 
confirmation screen. 

­ ¬ 

 
 After installing SquirrelView an example setfile will be installed within the SquirrelView 
 installation directory. The example file will log the internal temperature of the logger.  
 In order to familiarise yourself with the logger the novice user may find this example 
 Setup useful. 
 
4.1 Start SquirrelView and Select Logger Type 
 Click on the shortcut icon on your desktop to launch SquirrelView or select it from your 
 start menu. When the SquirrelView Assistant is loaded, ensure the correct logger type 
 and communication method is selected.  
 
 Logger type can be viewed from the SquirrelView assistant, if you need to make any 
 changes select Logger Selection from the toolbar or run the Communication Wizard. 
 (Note: the default communication method is USB and you will need to change this via 
 the Communication Wizard if you are using any of the other communication methods). 
 
4.2 Synchronise Logger & PC 
 It is advisable to start by synchronising the Logger clock with the PC clock.  



 

Version 13ï Nov 2009   18108 
Page 9 

 www.grant.co.uk 

 

    The Logger 
Setup screen  
is now visible,  
from here you  
will be able to  
set up your  
logging  
requirements. 
 
Within the  
Actual  
Channels tab  
scroll down the  
Sensor Type  
column to Ref.  
Junction 1.  
This is the  
input you will  
be reading in  
this example. 
 
    The Job  
Description  
can be used to  
describe your  
setup. 

    In the SquirrelView  
Assistant click óLogger 
Setupô to enter the Logger Setup 
screen. From here open the 
demo setfile using  File -> Open 
and select the appropriate file for 
your logger type. 

4.3 Running Quick Start Demo 

®    

­    

¬    

¬ 

­ 

® 
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    Click  
to send  
setup to  
logger  
and start  
logging. Let the unit  
log for a few  
minutes. 

    Click for 
Squirrel-
View  
Assistant. 

    Click  
if you  
wish to  
meter  
the input  
in Real Time. 

    Click on  
Logger  
Control  
to view 
status of 
logger 

    In the Logger  
Control window  
you can view  
various status 
information.  
 
To stop logging, 
click on the stop 
button. 

 ̄ ° ± ² 

³ 

 
    To Download the logger, click on 
the óDownload Dataô icon from the 
SquirrelView Assistant. 

 ́
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µ In this screen you can now download the Data File and invoke the Export Wizard or 
download the Data File to Analysis* (See Download Process Explained). 
 
The data File is given a unique name  
(e.g. 28162735.D20). An explanation of  
the file name is shown on the right; this  
shows the date and start time 
 
 

In this example you will download and view the Data in the Analysis* window. Start by 
selecting the Data File and Graph Data action, then click Download Selected File(s). 
You will be prompted to save the Data file, then the data will be converted for viewing. 
 
 
 
 
 
     Once the decoding has  
taken place the Analysis File  
Description window will be  
presented, click OK to view  
your Data. 
 
 
 
 
 
 
 
 
 
 
 
*Available with SquirrelView Plus only. 
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5. Download Process Explained 

Data File 
in  

external 
MMC/SD 

card 

Logger 

Data Files 

Analysis File 
(Plus Only) 

Analysis (.d20) 

(.d20) 

Reader 
Export 

(.xls) 

(.csv) 

Comma Separated Values 

Microsoft Excel 

SquirrelView 

The Diagram above shows the download process. Data in the logger is written to the internal 
memory and may be downloaded by SquirrelView.  
 
Before the data can be viewed it must be converted by SquirrelView for Analysis or exported 
to .csv or .xls format depending on the PC software being used. 
 
The conversion process can be performed in one of three ways within SquirrelView: 

- from SquirrelView assistant->Analysis->Export Data File 

- automatically when using the download Data button from SquirrelView* 

- or from the Logger Data Analysis screen by selecting File->Import Data menu* 

 
Once the file has been downloaded it can be double clicked to open it with the program specified 
under óToolsô, óPreferencesô, óFile Association Actionô. 
 
 
 
 
 
*Available with SquirrelView Plus only. 
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6. Menu and Navigation 

6.1 Control Panel 
 The illustration below shows the navigation controls in more detail. 

  
 To use the 2020/2040 control panel 
  press      .   
 
 The display timeout is preset  
 to 10 seconds, this can  be changed in 
 the Configuration tab within the Logger 
 Setup window of SquirrelView. 

LEFT 
NAVIGATION 

ESCAPE/BACK 
(reverts to previous 
Menu) 

RIGHT 
NAVIGATION 

ENTER/CONFIRM & 
POWER ON 



 

18108  Version 13 - Nov 2009 
Page 14 

 www.grant.co.uk 

 

EN 

 
6.2 Control panel menu 
 Detailed below is a basic explanation of the top menu structure. For more information on 
 the whole menu structure please refer to the Help->Help Content->Loggers within 
 SquirrelView. 

6.3.1 Log Control 
 In this menu you can Arm (activate) or  
 Disarm (deactivate) the logger.  
 
  
  
6.3.2 Meter 
 Here you can view each channel in Real 
 Time (at 1-2Hz). Use the Enter key to auto 
 scroll through the channels. 
   
  
  
6.3.3 Status 
 The Status menu gives you access to  
 information relating to the logger such as 
 memory and power supply voltage. You 
 can also override the alarm outputs in  
 here. 
 
 
  
6.3.4 Setup 
 This contains menus for setting up  
 Language, Time & Date and the  
 opportunity to store and recall Setups. 
 
 
 
6.3.5 Data Files 
 This menu allows you to copy data files to 
 an external memory card (if fitted) and  
 delete the data files held within the  
 loggerôs memory. 
  
 
  
6.3.6 Tools 
 The Tools menu contains maintenance 
 type functions such as querying the        
 software version or IP address of the  
 logger, performing a self test and resetting 
 the logger.  


